Jump to content

Recommended Posts

Has anyone else having problems getting their iKamand to connect?   I've spent around eight hours now trying to get the iKamand unit to connect to the app/internet.   I've been emailing customer support since 9:00 this morning and they haven't been able to help.  I disabled the 5ghz WiFi band, re-booted the router, deleted and re-installed the app, all without success.  If anyone has any suggestions it would be appreciated.

Share this post


Link to post
Share on other sites

How far is your router from the unit? Maybe try moving the router to a different location. The problem could

be due to a weak signal. You might even try moving the iKamand near the router just to see if the two will talk to

each other. Hope that's all it is and not a bad device. Good Luck.

 

Share this post


Link to post
Share on other sites

Make sure you're near the router when you're first setting it up. Shouldn't have to be super close, but just plug it in to a wall outlet in the same room or something. Be sure you're connecting your phone to the iKamand's wifi network that it makes itself like it says in the instructions, not to your own home network. Once you're connected to the iKamand wifi, then put in your wifi login info exactly, making sure it's all correct.

If your router has separate 2.4ghz and 5ghz networks, name them something different and have them separate and then just use the 2.4ghz one for the ikamand.

Share this post


Link to post
Share on other sites

I haven’t encountered your problem. 

 

I have had other devices that work better on a separate network, they are on my “guest”. 

 

Are you able to connect to the IKAMAND when you put the device into setup mode? iOS or android? 

Share this post


Link to post
Share on other sites

are you using your phone? when its connecting it needs to access the internet  not using the wifi  I couildnt set up the ikamand with the ipad but when I switched to phone it connected right away

Share this post


Link to post
Share on other sites

Thanks to everyone who chimed in.  My issue got elevated to someone who could call me.   They had me try the guest network and it worked.   They aren't sure why but it did the trick.  I had not tried the guest network as it has a space and the FAQ's say it won't work.  We use an underline for the space so that seems to work.  Her other concern was special charters in the password.  Our password has a ? and a # so one of those may be an issue.   I was not going to change the password and have to update 20 other devices though. ;-)

Tomorrow will be a test cook of a brisket.  I'll post about it when it's done.

 

Thank you again for the advice.

Share this post


Link to post
Share on other sites

I also had issues connecting.  Took around three nights, and hooking it up to my neighbors WiFi to boil it down to my router.  I had done everything, hard restarts, disabling the 5g network, soft resets, discussions with Kamado Joe, discussions with Spectrum internet, etc to no avail.  I finally replaced the router with our internet provider and it worked the first time.  Couldn't find a good reason for the old router to not work on the ikamand as all of our other devices (TV, ipads, phones, etc) were working fine...but that fixed it.  Since then it has worked great!

 

How has the temp control been for everyone so far?  I had my top vent open too wide on my first cook and overshot my temp...

 

Also, I was a user of the "The MEATER" product, which didn't connect great through bluetooth (many cooking sessions were cut short due to connectivity issues)- however the app itself was very nice and more robust than the current KJ app.  It had a built in alarm that you could add personal times to for flipping, basting, etc...

Share this post


Link to post
Share on other sites

Is this still in testing?  If yes, I would be more than happy to test a unit out.  When do you expect it will be out for sale and how much do you anticipate the price being?

Also...I noticed something about the top vent being opened too much on one of the posts....are there recommendations for the proper position of the top vent?

I have been using my KJ 24" for a few years now and love it but it would be awesome if I could regulate the temperature remotely.  That way I would not be tied down to staying near it on a long cook.  Don't get me wrong...once you get it dialed in, it is amazing how it stays at the temp you set, but it does take a little while to regulate when you add wood or have a big ol' hunk of cold shoulder on it. 

Best of luck with this device...if it works as advertised, it should be a huge success (unless it costs an arm and a leg). :)

Share this post


Link to post
Share on other sites

Had a similar issue. My regular WiFi password has special characters (#!& Etc) I set up a guest network with a simple password and it connected right away.

Share this post


Link to post
Share on other sites

I had the exact same thing happen. It seemed easy to setup, and I have an Apple extreme as a WiFi extender and an extreme base station. Everything else in my house connects fine (Sonos is even farther). I really don’t want the hassle of buying another range extender or moving routers from the office for a bbq tool.

Share this post


Link to post
Share on other sites

To be fair, there has been updates applied to fix the above issues. I believe there working on ironing out the bugs with the unit granted not quickly but there chomping away at the bit. Here is a link to the KJ website where they post the fixes and what they fixed.

 

https://ikamand.freshdesk.com/support/solutions/articles/36000034170-ikamand-and-app-update-history

Share this post


Link to post
Share on other sites
6 hours ago, bel4_20 said:

To be fair, there has been updates applied to fix the above issues. I believe there working on ironing out the bugs with the unit granted not quickly but there chomping away at the bit. Here is a link to the KJ website where they post the fixes and what they fixed.

 

https://ikamand.freshdesk.com/support/solutions/articles/36000034170-ikamand-and-app-update-history

 

It’ll probably take another 6 months to iron out the kinks.  The first CyberQ units were plagued by issues as well.  KJ is trying to do something much more comprehensive than anything BBQ Guru or the other companies are doing.  There’s bound to be some growing pains here. 

 

Hopefully by the spring of 2019, they’ll have all the bugs worked out. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×