Jump to content

jrow17

My recent Traeger cooks

Recommended Posts

Hey gurus I know I’ve been gone a while and yes it’s the same ol song and dance with me being busy all the time. But I always have time to cook:) and here lately I’ve added a few cookers to my arsenal. I added a Traeger Timberline 1300 pellet cooker and a Rectec Matador but I will post on the Matador later.

here are some pics of some of my Traeger cooks. Thanks for looking!!

5A6F3A82-0501-49A4-B7AC-2F9257384F00.thumb.jpeg.33ea1e208565f408dec2a352b3051590.jpeg5A6F3A82-0501-49A4-B7AC-2F9257384F00.thumb.jpeg.33ea1e208565f408dec2a352b3051590.jpegB12343E7-EDBA-4780-8985-9B843BBBFCFF.thumb.jpeg.35ed453ca7935fd85ba91247c6566cbc.jpeg8E2A04A3-66E6-4E52-8C1E-CC27EF115FC5.thumb.jpeg.5a33e9954f16319cb59f1fb7b99838e7.jpegD29C721B-FCB5-42AD-9E9D-FCC49285CDDB.thumb.jpeg.b5c8d991ed923a8caec5d2d2760ab020.jpeg1FFE3ADE-10F8-4129-9F9B-B8077133CDC5.thumb.jpeg.fbea916e88b89499273b6ff599d4bbd9.jpeg581C34F0-A610-47E8-99FC-62B0D14BC17A.thumb.jpeg.12bd4af1a647d81120776b63aa1aabc4.jpeg045130EB-6C2F-4A37-AB3F-C71661947150.thumb.jpeg.27f0589563191ed57a8782009a6f18fd.jpeg5111D381-465A-4E27-8F33-F40E5C376A07.thumb.jpeg.9151adad83e98439c958608bca1c2e4d.jpegC69C7C2F-6B4F-400E-8DD4-9911209F220A.thumb.jpeg.2ecf19b9eedbcfd6f420494c2a585097.jpeg

Share this post


Link to post
Share on other sites
1 hour ago, freddyjbbq said:

 

I have wondered about your thoughts on this topic :afro:

 

youre family has a 1300? Is that right? 

 

Yes.  We have an early 1300 from before the bugs were worked out. I want to love it, but I’m a little bit jaded. We had to operate on it multiple times. I’ve spent more time under that thing than I have cooked on it I think.  I wish we had waited until the glitches were worked out before we got one. But we didn’t know about the glitches when we got it.... Lots and lots of calls to customer service and waiting on parts and installing parts. 

 

All these cooks have me thinking I should give it another shot with an open mind. Lol. 

Share this post


Link to post
Share on other sites
9 minutes ago, KismetKamado said:

 

Yes.  We have an early 1300 from before the bugs were worked out. I want to love it, but I’m a little bit jaded. We had to operate on it multiple times. I’ve spent more time under that thing than I have cooked on it I think.  I wish we had waited until the glitches were worked out before we got one. But we didn’t know about the glitches when we got it.... Lots and lots of calls to customer service and waiting on parts and installing parts. 

 

All these cooks have me thinking I should give it another shot with an open mind. Lol. 

 

I agree that you should revisit it and if it continues to be a problem then escalate through customer service to a manager.

 

I’d be surprised if they didn’t replace the whole unit.  My Dads Ranger came with a ding in the hood & I thought they’d replace the sheet metal but ended up sending a whole replacement Ranger 

Share this post


Link to post
Share on other sites
58 minutes ago, KismetKamado said:

 

Yes.  We have an early 1300 from before the bugs were worked out. I want to love it, but I’m a little bit jaded. We had to operate on it multiple times. I’ve spent more time under that thing than I have cooked on it I think.  I wish we had waited until the glitches were worked out before we got one. But we didn’t know about the glitches when we got it.... Lots and lots of calls to customer service and waiting on parts and installing parts. 

 

All these cooks have me thinking I should give it another shot with an open mind. Lol. 

 

depending on the issues that you are having my guess is that you auger is too long. They also have since removed the fan collar from their units.  Upgrade to version 2 software and you will be set.  

 

I would call and ask for a new auger and remove your fan collar.  That is the only changes that were made to the 1300 from first production.  The software update fixed 90% of the issues.

 

 

Share this post


Link to post
Share on other sites

We removed the fan shroud early on and have replaced the auger.  We have it tied into the WiFi so I assume software is up to date. I still get a lot of smoke coming out of the pellet hopper. Not sure what that’s all about.... It’s not sooting as bad now, but still seems to be more so than our GMG we got rid of... but maybe that’s just me and my imagination still feeling jaded lol. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×