Jump to content

Ducatiman

Joetisserie motor stops mid-cook

Recommended Posts

The last the two times I’ve use my Joetisserie, the motor stops for some reason. First time I tried several other sockets and didn’t work that night. Next morning, the motor was fine.

 

Last night I was using it and stopped it to check the temperature of my chicken and then turned it back on and came back 15-20 minutes later and it wasn’t spinning but the chicken was done. When I took it off, I then tried the motor without the spit and it worked.

 

Anyone else having issues with their motor?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...