Jump to content

Masterbuilt 560/1050 Rotisserie glitch


Recommended Posts

Did my first rotisserie cook yesterday using the Masterbuilt rotisserie and while I made to the end of the cook the unit tried to stop working towards the end.

After an hour the shaft started making sort of a clicking/grinding noise, stop and reverse rotate.

A few times it stopped completely and so I turned it on and off a few times which got it going again.

I could not see anything wrong and it was too hot to play with so I let it finish cooking and cool down.

This morning I find that the hollow driveshaft socket/screw that goes from the inside left cook chamber panel into the drive motor head was unscrewed and wanting to fall out, which i to say I was able to pull it out of the drive head with fingertips, no wrench needed.

It has an outer hollow body with threads on the outside diameter which engage the drive head and hold it tight against the left panel and it has an inner round piece of metal that goes through the outer screw body and engages the drive head with the other end having a square socket which drives the rotisserie shaft itself.

Turns out the inner socket piece galled in the outer screw head and had locked up tuning both bits into one lump.

When the drive socket froze up it locked the rotation of the motor and shaft and the drive head reversed itself which unscrewed the screw body from the drive head which then allowed the entire frozen screw body and drive socket to rotate counter clockwise and while loose and floppy, it allowed the shaft to rotate and the cook to finish.

I sprayed the stuck bits with penetrating oil and tapped the stuck socket out of the screw body and found a lump of metal on the socket outer diameter where it had galled and welded itself to the inner diameter of the screw body.

I filed and sanded the galled spot and polished and lubricated the interfaces with some hi temp lithium grease designed for high load drive shaft teeth and now all is as it should be.

I could/can not find a way to talk to a human at Masterbuilt to report the galling/sticking or to ask if perhaps the instructions should have mentioned add some grease to the interface.

 

In the picture of the cooked bird you can see the screw/sleeve backed out of the drive head leaving a gap between the flange and left body panel.

 

DSC00446.JPG

DSC00447.JPG

DSC00453.JPG

Link to comment
Share on other sites

  • 7 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...